区块受错误影响,可能无法正常运行

新年新气象,把Wordpress也升级到了5.8.2,其实这个版本早发布了,但因为我关闭了自动更新及提示,所以一般升级一次会用好久,以致中间可能会跳跃几个版本。

发现新的版本带来了许多新功能和改进,其中感知度比较强的是小工具模块也使用区块编辑器管理小工具。现在在小工具区添加区块,也可通过定制器进行实时预览。

区块受错误影响,可能无法正常运行

小工具这一编辑方式的改变,也导致本站主题下的小工具出现罢工了。每个小工具下都出现错误提示:

“xxx”区块受错误影响,可能无法正常运行。请检查开发者工具以了解更多详情。

好在Wordpress提供了和编辑器一样的解决方案,后台安装插件页面搜索“Classic Widgets”,安装并启用,问题就解决了!

不过可惜的是根据插件的介绍,官方有可能维护直到今年就不维护了。

经典小工具是 WordPress 团队维护的官方插件,用于恢复过去的经典 WordPress 小工具设置界面。此插件将至少维护至2022年,或维护至任何必要时候。

插件一经激活,便会恢复过去的经典 WordPress 小工具设置界面,并禁止使用区块编辑器管理小工具。本插件不提供其他配置,通过启用或禁用此插件,可以启用或禁用经典小工具设置界面。

当然还有一种解决方法就是把Wordpress程序降级,不过不建议使用这种方法。

昨天发现插入的腾讯视频莫名其妙都挂了,原因暂时不明!

看来还是得抓紧找个新主题了!

阿和, Mr.Chou, 阿锋等人对本文发表了6条热情洋溢的评论。
  1. 阿和说道: 5 来自天朝的朋友

    我也没有这样的烦恼。傻瓜式就是有这个好处😝

    1. 老王说道: 来自天朝的朋友

      你那个如果弄直接从程序下手,asp还是方便些!😅

  2. Mr.Chou说道: 4 来自天朝的朋友

    我就没有这样的烦恼,官方一直不推正式版也没得升级,哈哈。

    1. 老王说道: 来自天朝的朋友

      反正你又不喜欢折腾 😂

  3. 阿锋说道: 0 来自天朝的朋友

    新版本对小工具影响很大,尤其是老主题。

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注